What's new
Learn Japanese with JapanesePod101.com

How to Type Japanese

Perhaps it's just the font in that gif....it just shows a dot followed by the line. But thanks, wasn't sure whether the dash was used or some other sign instead.
I have found an online Japanese typewriter at lexilogos which I am finding quite helpful. Now I can type in Japanese without installing any program on my computer! :)

Sure it takes a bit longer to find the right kanji, but with the use of my Random House Japanese-English-English-Japanese Dictionary, it will be a bit easier for me when I want to type a word in Japanese with ナ?ツソナスナ。! :)

Now, I can type 窶愬停?ケナセ instead of Tokyo. 😌
Has anyone talked about an iPod or windows computer?

Last edited:
On my Mac if I select Hiragana and type in capital letters the output changes to katakana. However, if I select katakana and type in caps I still get katakana. I am coding my own Japanese software and so wanted to know how common this convention is. Is it safe to assume that if someone capitalizes a phoneme they want it in katakana?
I'm having some problems with my Japanese windows keyboard configuration. Up until a few days ago it worked fine, but I must have pressed something and changed the configuration, because now when I press ALT+ENTER, instead of alternating between hiragana and normal text, such as how I'm writing now, it alternates between hiragana and this strange kind of text. So to go back to normal text I have to click on the option on the language bar, which is a bit annoying as I change between hiragana and normal text quite often. Any idea how to get it back to the way it was before? The Microsoft IME settings are in Japanese, in a level too advanced for me to understand and I really don't want to fidget with the options, just in case I make the problem worse.
Not Alt-Shift? (to switch between languages). Which Windows version?

At any rate, looks like you've gotten stuck on "full width". The easiest thing to do, if you didn't fiddle with the settings originally, is probably to look for some "reset to default settings" button. Or see if there's any reference in the settings to 半角 and 全角 (you want it to default to 半角英数).
It's Windows 7. Yes, I can change between languages, didn't know I could, thanks for that. Before I could change between hiragana and normal text with shift+caps though (wrote alt+enter before, my bad) Now, when I do it, I change between wide text and hiragana. I guess I'll just stick to changing between languages until I find a solution for it. Thanks :)
Found something (in Japanese, but there are screenshots). Someone who bought a PC while they were in the US, and sounds like a similar issue.

Seems like you need to go to properties (プロパティ) (from the IME toolbar) , then autocorrect (アートコレクト) tab, and check under 英字 that the setting is 常に半角に変換 (always convert to half-width).
If you're going to be inputting Japanese a lot, I would suggest you try the Google IME. In my opinion it beats the pants off the one from Microsoft.
At this moment, it is pretty easy to type hirigana and romaji on my computer. Katakana is a bit harder and you must trick the computer to pick the right kanji.

Using kanji on my computer can be done... by going to Google Translate, draw the kanji with the mouse. A list of possible kanjis are shown and you pick the one, you want to use.

Although maybe nobody expect it, but typing Japanese on my smartphone is easier than on my computer. I have a Japanese keyboard on my smartphone. There are several kanji possibilities I can pick of. For katakana I must use tricks.

On my iPad there is a real kanji keyboard. I don't know how to use it when I try to type some easy kanji like: 五 or 人.

Maybe there are smarter tricks.
Maybe there are smarter tricks.
After installing an IME, type the correct reading of the word or the full sentence/clause instead of inputting individual kanji one by one. For instance, input ごにん, hit the space key, and select 五人 from the drop down list, then you can get the compound word 五人 directly at once. Or, input ごにんのせいとがくらすにいます, and hit the space key, then you can get the correct kanji 五人 and a katakana word クラス without being annoyed by homophones such like 誤認 or 暮らす. This is the way of inputting sentences most natives use.
Maybe there are smarter tricks.

Here are two tricks from me:
1) Adding a third language to keyboard layouts may lead to confusion in switching between languages via hotkeys. Like when i need to switch from Japanese to Russian i may press alt+shift and start typing only to discover later that i was typing in English. The solution that works form me is to have two input languages (Russian and Japanese) in my Windows language settings and then simply add English layout to Russian language and then redefine hotkeys. Now when i need to switch between English and Russian (or Dutch in your case) i press Alt+Shift, but when i need Japanse i press Ctrl+Shift.

2) Whichever IME you choose - i suggest you learn different hotkeys as soon as possible, since they make a big difference in typing tempo. For instance if when i need a passage converted into katakana i simply press F7 (Microsoft IME). Like if i type わたしのなはゆーりいです。and press spacebar, IME 's suggestion will be 私の名はユー理意です。which is not my name. What i do then is type わたしのなは{spacebar,enter}ゆーりい{F7,enter}です。{enter} and get a proper 私の名はユーリイです。
Having always had Japanese keyboards, I never realized what a pain in the butt Japanese input must be for those who don't.

Why not just get a Japanese keyboard for your computer?
Having always had Japanese keyboards, I never realized what a pain in the butt Japanese input must be for those who don't.

Why not just get a Japanese keyboard for your computer?
It's not so bad these days. I don't think the keyboard changes anything. You still need to switch between input modes.

I think it's Command+Space. I haven't set my Mac back up since returning to Japan, so I'm not 100% certain.
Turns out I needed to go into System Preferences > Keyboard and turn off Spotlight Search and turn on the language toggle and now this works and I'm all set. Yay!
Having always had Japanese keyboards, I never realized what a pain in the butt Japanese input must be for those who don't.

Why not just get a Japanese keyboard for your computer?

I recently picked up a small laptop in Japan and the Japanese keyboard gives me a bit of trouble in that the space bar is shorter so it doesn't reach as far on the right side. It's been a royal pain trying to get used to it. Added to the fact that the right side of the spacebar isn't very sensitive (I'm guessing the switch is closer to the left side, that's what it feels like) andItypelikethisalot.

It's a chromebook and, interestingly, one can turn on the same autocorrect features of android phones and tablets, but I can't get it to work with the Japanese keyboard even typing in English.
I don't find it that bad - I've got a laptop so can't really change the keyboard, what I do is to leave it on Japanese keyboard settings (only shifts a couple of things around), and then it's one key combo to switch.

On Android I use the PObox touch keyboard, which is flick-input or and a fuller keyboard with direct kana, depending on direction you hold the phone. That's an easy switch between languages, too. I do find that Android really benefits from switching the whole system over to Japanese, as it's often difficult to set languages app to app.
I have added Japanese as an additional language to my computer settings and now I can comfortably type in Japanese. I also use lexilogos online Japanese keyboard.
Is there a way to set default input mode to hiragana in IME? There is a a 初期入力モード setting, but switching it to ひらがな has no effect. Default input is still alphanumeric, which betakes that extra Alt+CAPSlock every time. Quite annoying.
Top Bottom