What's new

JWP question

RMiyazaki

後輩
31 Jan 2004
1
0
11
this is a JWP question. i have win/xp on a toshiba nb. how do i copy japanese text from notepad/ie/ns to jwp and have it display correctly. i tried changing the jwp clipboard to euc, s-jis, new-jis, etc. it still shows up as ??? when i paste into jwp.

...randy
 
Originally posted by RMiyazaki
this is a JWP question. i have win/xp on a toshiba nb. how do i copy japanese text from notepad/ie/ns to jwp and have it display correctly. i tried changing the jwp clipboard to euc, s-jis, new-jis, etc. it still shows up as ??? when i paste into jwp.
...randy

Check you have the latest JWPce version. Reset all options to default. 'Cuz I have Win XP and it works just fine for me.

Here's something copied from WWWJDIC to JWPce to here ...
文字化け 【もじばけ】 unintelligible sequence of characters
See, not mojibake ... oh wait ... see, still mojibake ... Meh, maybe I should have chosen different text to copy.

Mine's set to the default - Clipboard Import [Auto-detect]
Export [Shift-JIS].

If you still don't get it working then you can try setting your computer to use Japanese code pages as default for non-unicode programs.
 
I sort of have this problem from Outlook Express also. Since apparently Outlook Express only has JIS encoding for Japanese, when there happens to be regular text (non-JIS) mixed with the JIS text, and I copy all of it and paste it to JWPce, it would show ?'s.
So I had to copy the Japanese and others separately.

Though it doesn't happen with EUC and regular text.
 
Originally posted by Keiichi
I sort of have this problem from Outlook Express also. Since apparently Outlook Express only has JIS encoding for Japanese

You can only enter Japanese text in
- JIS
- UTF-7
- UTF-8
but it can display text in more formats. In fact the one format you can't specifically choose to select to view a message is JIS. You have to select Japanese (Auto-select) instead. Exactly what's up with that is one of the lesser mysteries of the universe.

, when there happens to be regular text (non-JIS) mixed with the JIS text, and I copy all of it and paste it to JWPce, it would show ?'s.
So I had to copy the Japanese and others separately.

Though it doesn't happen with EUC and regular text.
Is that when editing a message in Outlook Express or when Viewing one?

I've just checked on my computer with randomly selected message text of English/Japanese/English and had no trouble.
 
Sorry, I'll re-type what I said. After looking at your message, it became a bit more clear. :)

You're right about that you can't specifically choose to view a message in JIS (in Outlook Express) and have to choose Auto-select. Mystery it is. So what exactly is Auto-select using to view with? JIS? It's not EUC nor Shift-JIS, as manually trying both shows funky symbols.


Originally posted by PaulTB
Is that when editing a message in Outlook Express or when Viewing one?

I've just checked on my computer with randomly selected message text of English/Japanese/English and had no trouble.
It's both, viewing or editing, then when I copy it whole (from the email message to JWPce), it'll show the ?'s (though the ascii text from the email shows fine, thus it's probably pasting into JWPce as ascii). My JWPce currently has Import set to Auto-Detect. Going from JWPce to the OE's editing message box is fine though.

All this is not really that much of a biggie. Though does make life a bit easier. :p
 
Originally posted by Keiichi
Sorry, I'll re-type what I said. After looking at your message, it became a bit more clear. :)

You're right about that you can't specifically choose to view a message in JIS (in Outlook Express) and have to choose Auto-select. Mystery it is. So what exactly is Auto-select using to view with? JIS? It's not EUC nor Shift-JIS, as manually trying both shows funky symbols.
Quite right. It _is_ JIS - but it isn't admitting that it's JIS.
My theory is that the guy writing Internet Explorer (actually used to view messages in Outlook Express) didn't get his act together with the guy writing Outlook Express. :p 'JIS' is probably 'disapproved' by MS - maybe because it isn't much used in WWW pages while JIS is used a lot in email/newsgroups. (The latter because it is a 7-bit safe encoding).


It's both, viewing or editing, then when I copy it whole (from the email message to JWPce), it'll show the ?'s (though the ascii text from the email shows fine, thus it's probably pasting into JWPce as ascii). My JWPce currently has Import set to Auto-Detect. Going from JWPce to the OE's editing message box is fine though.
As far as I can see the only difference in my set-up is I have set "Non-unicode programs use [Japanese] code-pages".

You might as well try it on a temporary basis - if you don't mind all your backslashes looking like yen you can stick with it if it helps.

I need that setting for playing old Japanese computer games...
 
Back
Top Bottom